Intermittent Payment Processing Failures
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Oct 17, 2019 - 14:57 PDT
Monitoring
Our payment processor has reported intermittent failures. A fix for this issue has been deployed. We will continue to monitor its status and update accordingly.
Posted Oct 17, 2019 - 10:54 PDT
This incident affected: Website, iPhone App, and Android App.