Spike in 504s
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 09:25 PST
Investigating
We have detected a spike in 504 errors for customers on the shared infrastructure. We expect this to be resolved within 10 minutes. We apologize for the inconvenience.
Posted Nov 16, 2020 - 09:00 PST
This incident affected: Website, iPhone App, and Android App.