Home page is down
Incident Report for MyTime
Resolved
While we work with our website hosting service to restore our homepage, we are temporarily redirecting www.mytime.com to https://www.mytime.com/users/sign_in so that our existing users can login.
Posted Nov 06, 2019 - 13:08 PST
Investigating
https://www.mytime.com is down, but users can still login through https://www.mytime.com/users/sign_in. We are currently investigating and will follow up with updates.
Posted Nov 06, 2019 - 12:06 PST
This incident affected: Website.