DNS Issues
Incident Report for MyTime
Postmortem

DNS Resolution errors originated from our DNS provider, Cloudflare. Here is their incident page: https://www.cloudflarestatus.com/incidents/b888fyhbygb8

Posted Jul 17, 2020 - 15:10 PDT

Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 15:08 PDT
Update
The DNS issues have now resolved themselves. We are continuing to monitor. as we may still see some intermittent failures.
Posted Jul 17, 2020 - 14:54 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 14:52 PDT
Monitoring
Some customers are not able to access mytime.com. We have identified that there are widespread DNS errors causing this, and we are closely monitoring the situation.
Posted Jul 17, 2020 - 14:52 PDT
This incident affected: Website, iPhone App, and Android App.