Site loading issues
Incident Report for MyTime
Postmortem

At approximately 7:40am PDT, the web application failed to load data onto the page.  The backend server and code path continued to function normally, which meant the MyTime Scheduler mobile apps, online booking, and all APIs continued to function normally.  The MyTime engineering team responded and discovered an issue with LogRocket, a third-party application used to record user click paths to diagnose issues reported to customer service, was blocking the JavaScript from loading in the browser.  MyTime engineering did an emergency deploy to remove LogRocket from our application, but before this deploy could even be completed, the MyTime application began to load again at approximately 9:30am PDT.  We believe that LogRocket fixed the issue on their side which allowed our site to function normally again.

Indicated Actions: Given this issue and its severity, we have decided to remove LogRocket entirely and permanently from the MyTime application, as this incident has indicated to us that it is not worth the downtime risk should their application fail again.  We will also search for other dependencies that MyTime may have on third-party services so they can be disabled quickly without a deploy.

We’re sorry for the impact this outage may have had on your business and will work hard to put in place processes to prevent this from happening again.

Posted Jul 12, 2021 - 10:17 PDT

Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 09:37 PDT
Update
We are continuing to investigate this issue.
Posted Jul 12, 2021 - 09:36 PDT
Update
We are continuing to investigate this issue.
Posted Jul 12, 2021 - 09:36 PDT
Update
To immediately fix the issue, there is a manual work around that you can do until the general fix is applied by 10am PDT.

1) In the browser, open developer tools by clicking F12 or right click on the page and click inspect. You should see a developers tools section open.
2) Click the Network tab
3) In the top left corner you can see an input box where you can type
4) Filter for `logger` or `log` to find logger.min.js
5) Once found, right click on the entry logger.min.js and click on `block request domain`
6) Refresh the page. The page should load normally after that.

Note: Please keep developer tools open.
Posted Jul 12, 2021 - 09:04 PDT
Update
A deploy to remove LogRocket has been started. The Web will be accessible again within 60 minutes (at 10am PDT) and may require users to do a hard refresh in the browser (Windows users: hold down Ctrl and then press F5 on your keyboard. Mac users: hold down Cmd and Shift and then press R on your keyboard).

We're deeply sorry for the downtime this has caused.
Posted Jul 12, 2021 - 08:04 PDT
Update
The iOS and Android apps are unaffected. We recommend using these instead of the web until the issue is resolved on Web.
Posted Jul 12, 2021 - 07:52 PDT
Investigating
The MyTime application on Web is failing to load due to some issues with LogRocket. We are removing the LogRocket integration temporarily so that the website will load.
Posted Jul 12, 2021 - 07:48 PDT
This incident affected: Website.