Lag on Payments Page
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Sep 19, 2020 - 11:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 19, 2020 - 11:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 19, 2020 - 11:09 PDT
Identified
There is a lag opening the take payment page on POS. The cause has been identified and the fix is being implemented now.
Posted Sep 19, 2020 - 10:38 PDT
This incident affected: Website, iPhone App, and Android App.