Report aggregation issue
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 09:56 PST
Identified
Report aggregation jobs failed and data is being regenerated. Some reports may contain inaccuracies for 24-36 hours (starting from 1/15/2020) until the data aggregation is completed. This issue primarily impacts larger accounts with large amounts of data. We apologize for the reporting disruption.
Posted Jan 15, 2020 - 08:58 PST
This incident affected: Website, iPhone App, and Android App.