Payment Processing Outage
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 12:19 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2021 - 12:10 PDT
Identified
We are continuing to see failing transactions after our initial fix. We believe we have identified the issue and are working to restore our payment service as soon as possible.
Posted Sep 30, 2021 - 12:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2021 - 11:43 PDT
Identified
The issue has been identified and a fix is being implemented.

There is no ETA on a fix but it is our top priority to get this fixed as soon as possible.
Posted Sep 30, 2021 - 09:41 PDT
Update
Customers using an Ingenico card reader do not appear to be impacted. Please use your Ingenico card reader if you have that available to you.

For customers who only use card on file or key in card, follow the steps below for a temporary workaround:

1. Enter the tip manually on the new ticket screen
2. Click Take Payment
3. Click the card on file or key in card to process the transaction
Posted Sep 30, 2021 - 08:35 PDT
Investigating
We are aware of an outage preventing MyTime customers from processing payments. We are working with our payment processing vendors to resolve this issue. We understand the urgency and it is our top priority to have payment processing restored as fast as possible.

In the interim you will need your customer to pay with cash OR for credit card payment you have the following options:

•if your customer has a card on file you can process the credit card payment when the issue is resolved
•at your own discretion and in accordance with PCI regulation guidance - write down the customer's card information and manually key-in the card information when the issue is resolved.
•contact the customer at a later time and manually key-in their card information
Posted Sep 30, 2021 - 07:48 PDT
This incident affected: Website, iPhone App, and Android App.