Cloud9 Payment Gateway issue with stored credit cards
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Sep 26, 2020 - 11:55 PDT
Investigating
Cloud9 payment gateway is experiencing an outage with tokenized (stored) credit cards on file. If possible, please do not use stored cards to take payment until this is resolved or you may receive a failure message.
Posted Sep 26, 2020 - 11:24 PDT
This incident affected: Website, iPhone App, and Android App.