Degraded performance for reports and emails.
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Sep 03, 2022 - 07:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2022 - 06:33 PDT
Identified
The issue has been identified and we are working with AWS on finding a solution.
Posted Sep 03, 2022 - 05:48 PDT
Investigating
We are currently investigating this issue
Posted Sep 03, 2022 - 05:47 PDT
This incident affected: Website.