Opening Register Lag
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 06:28 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 28, 2022 - 06:19 PDT
Identified
Our engineers are currently working on a deployment to fix and ETA is about 20 minutes
Posted Mar 28, 2022 - 06:18 PDT
This incident affected: Website, iPhone App, and Android App.