MyTime homepage down
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Jan 14, 2023 - 19:27 PST
Update
We are continuing to investigate this issue.
Posted Jan 14, 2023 - 19:27 PST
Investigating
MyTime's Wordpress-based homepage is not currently loading. Please login to the application directly at https://www.mytime.com/users/sign_in until the homepage is restored.
Posted Jan 14, 2023 - 18:52 PST
This incident affected: Website.