Urgent DB maintenance required
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 01:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2022 - 01:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2022 - 01:19 PDT
Investigating
We are currently investigating this issue.
Posted Sep 15, 2022 - 01:19 PDT
This incident affected: Website.