Degraded performance on data center
Incident Report for MyTime
Resolved
AWS has resolved the datacenter issues in the US-East datacenter and all systems are operating nominally. Their status page with updates can be found here: https://status.aws.amazon.com/
Posted Dec 07, 2021 - 17:30 PST
Investigating
Amazon Web Services (AWS) US-East region, where MyTime's US businesses are hosted, is experiencing degraded service. Their status page is down, but we are monitoring the incident through news channels. MyTime is currently operating but may be impacted with sporadic performance degradation until AWS resolves the issues.

https://www.datacenterdynamics.com/en/news/aws-us-east-1-outage-brings-down-services-around-the-world/
Posted Dec 07, 2021 - 09:28 PST
This incident affected: Website, iPhone App, and Android App.