Data Base Issues
Incident Report for MyTime
Resolved
This has been resolved and we are continuing to monitor the situation accordingly.
Posted Jan 17, 2023 - 15:55 PST
Investigating
We are currently experiencing database issues. Our engineering team is aware and currently working on restoring full functionality as quick as possible
Posted Jan 17, 2023 - 15:45 PST
This incident affected: Website, iPhone App, and Android App.