Outage impacting all card processing
Incident Report for MyTime
Resolved
Our credit card gateway partner, Cloud9, has worked with AWS to restore their service. However, there is still ACTION REQUIRED ON YOUR PART to restore your credit card terminal functionality if you use Ingenico terminals (this does not apply to merchants using Stripe Terminal). Please watch the video OR follow the steps below:

Video:
https://youtu.be/a3_8_iWgvzs

Link/2500, Move/5000, Lane/3000, Lane/7000, Lane/8000:
Press 2,6,3,4 key sequence and the reader will ask to ‘Press F for menu’. Press F.

Select TDA -> Configuration -> Communication -> Ethernet Settings -> Host IP Address -> enter 3.136.39.148
Use the # key to input the period “.” character. Press the circle green key to save.

Press the red X button until the terminal asks “Save and Reboot?“ -> Select Yes.

iPP320, iPP350, iWL258:
Press the 'F' key 4 times. Press 'F3' to select 'Change Settings'. Press 'Green' for DHCP, Press 'Green' for 'Client', Enter '3.136.39.148' for "Enter Host Address" and press 'Green', Press 'F4' to 'SKIP' entering Host Port, Press 'Green' for 'ON'(Select SSL Mode). Now press 'F1' to 'SAVE' the updates and reboot.

The card terminal will reboot. After it reboots it is ready for use.
Posted Oct 21, 2023 - 19:27 PDT
Monitoring
A fix has been implement. You can now process cards using key-in card.

Cloud9 is actively working on restoring the card terminals.

We will provide an update as soon as a fix for the card terminals is implemented.
Posted Oct 21, 2023 - 18:44 PDT
Update
We are pleased to report that Cloud9 and AWS are making significant progress towards restoring payment services. They have identified the root cause of the issue and have implemented a fix. They are currently testing the fix and monitoring the results.

We expect to have payment services restored very soon. We apologize for any inconvenience this has caused and we appreciate your patience as we work to restore full service.
Posted Oct 21, 2023 - 16:40 PDT
Update
Our gateway (Cloud9) is currently unavailable due to a hardware failure in one of their AWS (Amazon Web Services) data centers. They are actively working with AWS to restore service as quickly as possible.

In the interim, you will need to tender payments using cash. For credit card payments, you have the following options:
•If your customer has a card on file, you can process the credit card payment when the issue is resolved.
•At your own discretion and in accordance with PCI regulation guidance, you can write down the customer's card information and manually key in the card information when the issue is resolved. However, we strongly recommend you only do this as a last resort, as it is a security risk.
•Contact the customer at a later time and manually key in their card information.
Posted Oct 21, 2023 - 15:09 PDT
Identified
We have identified the issue with our gateway Cloud9. We are working with Cloud9 to resolve this issue as quickly as possible.

In the interim, you will need to tender payments using cash. For credit card payments, you have the following options:
•If your customer has a card on file, you can process the credit card payment when the issue is resolved.
•At your own discretion and in accordance with PCI regulation guidance, you can write down the customer's card information and manually key in the card information when the issue is resolved. However, we strongly recommend you only do this as a last resort, as it is a security risk.
•Contact the customer at a later time and manually key in their card information.

We apologize for any inconvenience this may cause. We will keep you updated on the status of the outage and will provide an estimated time of restoration as soon as we have it.
Posted Oct 21, 2023 - 13:48 PDT
Investigating
We are aware of an outage that is preventing MyTime customers from processing payments. We are working with our payment processing vendors to resolve this issue as quickly as possible. We understand the urgency and it is our top priority to have payment processing restored.

In the interim, you will need to tender payments using cash. For credit card payments, you have the following options:

•If your customer has a card on file, you can process the credit card payment when the issue is resolved.
•At your own discretion and in accordance with PCI regulation guidance, you can write down the customer's card information and manually key in the card information when the issue is resolved. However, we strongly recommend you only do this as a last resort, as it is a security risk.
•Contact the customer at a later time and manually key in their card information.

We apologize for any inconvenience this may cause. We will keep you updated on the status of the outage and will provide an estimated time of restoration as soon as we have it.
Posted Oct 21, 2023 - 13:34 PDT
This incident affected: Website, iPhone App, and Android App.