Database Reboot Underway
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 10:44 PST
Monitoring
We are undergoing a Database reboot to enhance performance. We will provide confirmation when this has finished.
Posted Jan 08, 2024 - 10:14 PST
This incident affected: Website, iPhone App, and Android App.