Site Outage

Incident Report for MyTime

Resolved

This incident has been resolved.
Posted Nov 08, 2021 - 13:39 PST

Monitoring

A fix has been made and we're monitoring the results.
Posted Nov 08, 2021 - 13:37 PST

Update

We are continuing to investigate this issue.
Posted Nov 08, 2021 - 13:27 PST

Investigating

We are aware of a high database load that is impacting performance and are investigating now
Posted Nov 08, 2021 - 13:27 PST
This incident affected: Website, iPhone App, and Android App.