Payment Processing Outage
Incident Report for MyTime
Resolved
Amazon Web Services (AWS) reported the issue has been resolved and connectivity has been fully restored.
Posted Dec 05, 2022 - 13:11 PST
Monitoring
Update from AWS - We are beginning to see signs of recovery, and continue to work toward full resolution.

https://health.aws.amazon.com/health/status
Posted Dec 05, 2022 - 13:08 PST
Identified
Amazon Web Services (AWS) is experiencing degraded service.

MyTime Payments will experience sporadic performance degradation until AWS resolves the issues.

To follow status updates: https://health.aws.amazon.com/health/status
Posted Dec 05, 2022 - 12:47 PST
Investigating
We are aware of an outage preventing MyTime customers from processing payments. We are working with our payment processing vendors to resolve this issue. We understand the urgency and it is our top priority to have payment processing restored as fast as possible.

In the interim you will need your customer to pay with cash OR for credit card payment you have the following options:

•if your customer has a card on file you can process the credit card payment
•manually key-in their card information
Posted Dec 05, 2022 - 12:30 PST
This incident affected: Website, iPhone App, and Android App.