Apple Pay and Google Pay Outage

Incident Report for MyTime

Resolved

The incident is now resolved.

Users still encountering problems must refresh their browser to load the latest updates.
Posted Sep 10, 2025 - 16:09 PDT

Monitoring

Apple Pay and Google Pay services have been fully restored.

• Web users: Please refresh your browser.
• Mobile app users: Please close and reopen the MyTime app.

Our team is actively monitoring to ensure continued stability.
Posted Sep 10, 2025 - 14:49 PDT

Update

A fix has been deployed, and Apple Pay and Google Pay functionality will be restored shortly.
Posted Sep 10, 2025 - 13:27 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 10, 2025 - 13:02 PDT

Investigating

We are currently experiencing an outage with Apple Pay and Google Pay on Ingenico terminals.

Clients can still complete transactions by:

•Tapping with a physical card
•Inserting a chip card
•Keying in card details

We are actively working with Cloud9 to restore Apple Pay and Google Pay functionality and will provide updates as soon as service is restored.
Posted Sep 10, 2025 - 12:38 PDT
This incident affected: Website, iPhone App, and Android App.