MyTime is responding slower than normal
Incident Report for MyTime
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 09:46 PST
Update
The issue is now resolved. YOU MUST REFRESH YOUR PAGE ON THE WEB BROWSER for MyTime to return to normal. Again, we are deeply sorry for this incident.
Posted Jan 08, 2024 - 09:14 PST
Update
The issue has been identified and the expected resolution time is 9:20AM PST. We are very sorry for the disruption to our application on the shared environment.
Posted Jan 08, 2024 - 09:10 PST
Identified
The issue has been identified and a fix is being implemented. ETA 30 minutes.
Posted Jan 08, 2024 - 08:51 PST
Investigating
We are currently investigating this issue.
Posted Jan 08, 2024 - 08:22 PST
This incident affected: Website, iPhone App, and Android App.